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Chapter 1  

Introduction 

The Online Marketing Suite Cookbook contains instructions for marketers and content 
authors working with Sitecore Analytics. This guide contains step by step instructions 
on the key tasks necessary in setting up and configuring Sitecore Analytics on your 
website.  

All of the examples in this cookbook use the Office Core website. This website is 
designed to highlight the functionality available in the Online Marketing Suite.  

You can download the Online Marketing Suite Cookbook and Office Core website 
from the Sitecore 6 References section of the Sitecore Developers Network. 

This cookbook contains the following chapters: 

 Chapter 1 — Introduction 
This chapter is a description of the content, aims, and the intended audience of this 
cookbook.  

 Chapter 2 — Creating and Configuring Analytics 
This chapter provides step by step instructions on how to create profiles, goals, 
campaigns, multivariate tests, and personalization. It also includes instructions on 
configuring these items in the Page Editor. 

 Chapter 3 — Assigning Analytics Values to Content Items 
This chapter provides step by step instructions on how to assign profile values to 
content items, how to associate goals and campaigns with content items, and how to 
assign events, failures, and settings. 

 Chapter 4 — Analytics Reporting 
This chapter provides information about the Sitecore standard reports as well as how 
to filter reports. 
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Chapter 2  

Creating and Configuring Analytics 

This chapter provides step by step instructions on how to create and configure 
analytics items in the Online Marketing Suite, Marketing Center. 

This chapter contains the following sections: 

 Content Profiling 

 Creating Goals 

 Testing 

 Personalization 
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2.1 Content Profiling 

Content profiles enable you to gain a better understanding of the behavior and actions of your website 
visitors. 

Marketers create content profiles and profile keys in the Marketing Center and content authors use 
the Content Editor to assign values the contents of each web page.  

When visitors come to your website they accumulate a profile score for each visit. This profile is 
based on the values assigned to the content that they view and is recorded in the session trail.  

Profiles 

Creating profiles and profile keys enables you to categorize the content on your website. So when 
visitors navigate through your site they accumulate a score that gives you an insight into the kind of 
content that they are interested in.  

Profile scores can be viewed as a bar chart in the session trail. This information helps content authors 
to identify areas for improvement on the site. It can also be used for segmenting site visitors and to 
create rules for personalization. 

Scores 

Scores give you an insight into a visitor’s level of interest in a website. For example, assigning a high 
lead score to an item, such as a brochure download page means that if a visitor views this page they 
have demonstrated a high level of interest in buying, so can be targeted as a potential sales lead. 

This information can be particularly useful to sales teams. For instance, lead scores can give an 
indication of future customers and sales.  

Examples of scores: 
 

Score Example 

Lead Pages related to price carry a high lead score on your website.  
Knowing which visitors achieve a high lead score could help a 
sales team to target potential new customers. 

Investor A visitor has viewed the annual report page on your site. 
Assigning this page a high investor score could indicate which 
visitors are interested in investment. 

Big spender Assigning a high score to page that records the total purchase 
amount of visitors on your site could indicate which visitors are 
the biggest spenders.  

The Office Core website is configured to record Lead scores to demonstrate this concept. The deeper 
a visitor navigates into the site, the higher their lead score. There are some exceptions to this rule, 
such as downloading a brochure which carries a higher lead score. In Sitecore Analytics, the lead 
reports are stored under the Sales node and the lead scores of each visitor are shown in the session 
trail. 

2.1.1 Pre-requisites 

Before you assign profile values to content items you should consider creating: 

 Website personas. 

 A profiling strategy. 

 A scoring strategy. 
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2.1.2 Creating Profiles 

To create a new profile: 

1. Click the Sitecore menu and then click Marketing Center. 

2. In the Marketing Center, click Profiles.  

3. In the Home tab, in the Insert group, click Profile to create a new profile definition item.

 

4. Give the profile a name, such as, Focus. 

5. In the Profile item, enter the appropriate field values. 

 

 

Field Value 

Name The name of the profile, such as, Focus. 

Type Select one of the following methods of calculation: 

 Average 

 Percentage 

 Sum 

This determines how profile values are calculated. 

6. In the Home tab, click Save. 

7. Click the Publish tab and then in the Publish group click Publish, Publish Item to publish 
the new profile.  
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8. In the publishing wizard, select the Smart Publish option 

2.1.3 Creating Profile Keys 

To create a new profile key: 

1. In the Marketing Center, select a profile such as Focus.  

2. In the Insert group, click Profile Key to create a new profile key definition item. 

Each profile can have any number of profile keys. 

3. Give the profile key a name, such as, Background. 

 

4. In the new Background item, enter field values. 

 
 

Field Value 

Name A name for the profile key, such as, Background. 

Control Select the type of control to appear in the Profiles dialog box: 

 Checkbox 

 Slider 

 Smileys 

 Stars 

 Text 

MinValue Enter a numeric value, such as, 1. 
This field can also be left blank.  

MaxValue Enter a numeric value, such, as 10. 
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5.  In the Content Editor ribbon, click Save. 

6. Publish the new item. In the publishing wizard, select the Smart Publish option. 

Note 
In the Sitecore Analytics training website there are four pre-configured profiles. Each profile 
has its own set of profile keys. You can extend or delete these profile keys as appropriate for 
your site. 

You can create any number of profiles and profile keys but it is worthwhile planning a profiling 
strategy before you start creating profile definition items. 
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2.2 Creating Goals  

Creating goals and campaigns enables you to measure the success of your website.  

Examples of goals:  

 Download a brochure 

 Register for an e-mail newsletter 

 Sign up for an online demo 

Once you have created some goals you can measure the conversion rate for each goal (the 
percentage of visitors that achieve a particular goal). The website performance reports show goals 
and conversion rates. 

To create a new goal: 

1. Click the Sitecore button and then click the Marketing Center. 

2. In the Marketing Center, click Goals.  

3. In the Home tab, Insert group, click Goal to create a new goal definition item.

 

4. Give the goal a name, such as, Register. 

5. In the new goal definition item, enter the appropriate values. 
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Field Value 

Name Enter a name of your goal, such as, Register  

Icon Select an icon for your goal.  
Click Open icon and select an icon in the Open File dialog box. 
 
To upload an icon of your own, click Upload in the Open File 
dialog box. 

Description Enter a suitable description, such as, User has registered. 

IsSystem This defines the event as a system event. 
For administrators and advanced users only. 

IsAuthorFeedback Select this checkbox to provide the content author with feedback 
on goals. 

IsGoal Select this checkbox to ensure that the goal appears in the Content 
Editor, Goals dialog box. You can then associate the goal with a 
content item. 

IsFailure Select this checkbox to define the event as a failure.  
For administrators and advanced users only. 

6. Click Save to save the new goal. 

7. Publish the new goal item. In the publishing wizard, select the Smart Publish option. 
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2.3 Creating Campaigns 

A campaign is a promotion or advertising initiative designed to encourage people to come to a 
website and perform desired actions. 

Sitecore Analytics supports two types of campaigns: 

 Online Campaigns 

 Offline Campaigns  

You can view reports that show which of your campaigns are the most successful. You can then 
improve or drop unsuccessful campaigns and improve your ROI. 

You create goals and campaigns in the Marketing Center. You associate goals and campaigns with 
content items in the Content Editor. 

To create a campaign: 

1. In the Marketing Center, click Campaigns, and then in the Home tab, in the Insert group, 
click Campaign.  

2. Give your new campaign a name, such as, Google AdWords Campaigns and click OK. 
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3. In the new campaign item, enter the appropriate values. 

 

 

Field Value 

Title The title of the campaign. 

Type The type of campaign — whether it is an online or offline campaign. 

Description A longer description of your campaign. 

Cost Monetary cost of the campaign. 
For example, Google AdWords campaigns have a cost per click. 

StartDate The start date for the campaign. 

EndDate The end date for the campaign. 

Hidden Whether or not the campaign should be shown in reports. 
For example, you may not want to show campaigns that are 
created automatically in your campaign reports. 

4. Click Save to save the new campaign. 

5. Publish the new campaign item. In the publishing wizard, select the Smart Publish option. 

2.3.1 Creating Campaign Events 

To create a campaign event: 

1. In the Marketing Center, select a campaign item and then in the Home tab, in the Insert 
group, click Campaign Event. 

2. Give your new campaign event a name, such as Award Winning Campaign and click OK. 
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3. In the new item, enter the appropriate field values.

 

 

Field Value 

Name The name of the campaign. 

Campaign Link This field contains a campaign query string.  
For example: 
sc_camp=7F967B85B627472AABE83F5F3DA51421 

Append the query to the link to your website provided on the 
sponsored site. If the link already includes a query string, prefix the 
provided text with an ampersand (&). If the link does not include an 
existing query string, prefix the text with a question mark (?).  
This ensures that site visits generated by this campaign are 
recorded in the analytics system. 

4. Click Save to save the campaign event. 

5. Publish the new campaign event item. In the publishing wizard, select the Smart Publish 
option. 
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2.4 Testing  

Sitecore Analytics lets you dynamically test the content of your website to find out which web controls 
are the most effective.  

You can create multivariate tests to see which combinations of text and images work best with site 
visitors. This can be particularly useful as a part of your strategy when setting goals and optimizing 
campaigns.  

The Sitecore Analytics MV Tests report gives you pre-configured statistics on your tests and includes 
data on the number of conversions that result from each test. 

2.4.1 Pre-requisites 

Before you can create a multivariate test, you need: 

 Two or more content items to use as test variables. 

 A control to use as the data source for your test. 

2.4.2 Creating Multivariate Tests 

In the following example, you will create a multivariate test for a newsletter form. Visitors to your 
website complete this type of form to register for an e-mail newsletter. In this multivariate test, you test 
three different combinations of text and graphics to find out which is the most effective. 

To create a multivariate test: 

1. Click the Sitecore button, and then click Marketing Center. 

2. In the Marketing Center, click Test Lab. 

 

3. In the Home tab, in the Insert group, click Multivariate Test to create a new multivariate test 
definition item. 
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4. Call your test Newsletter Form. 

 

5. In the new test item, enter the appropriate field values. 
 

Field Value 

Title The title of the test, such as Newsletter Form. 

Description A description of the test. 

Test Strategy Select a test strategy: 

 Random — the test variable changes for each page 
request 

 Sticky — the test variable changes for each visitor session 
(recommended) 

6. Click Save to save the new test. 

2.4.3 Creating Multivariate Test Variables 

Each multivariate test must have at least two test variables. Each variable represents an item of web 
content that you want to test. These content items must be created already. 

Create three test variables for the Newsletter Form test: 

1. In the Marketing Center, select the Newsletter Form multivariate test that you created earlier.  
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2. In the Home tab, in the Insert group, click Multivariate Test Variable to create a new test 
variable.  

 

3. For this example, create the following three multivariate test variables: 

o Big-Check 

o Medium-Arrow 

o Small-Red 

 

4. For each variable enter the following field values: 
 

Field Value 

Name A suitable name for the test variable. For example, Big-Check. 

Data Source A link to the content item that is the data source for this test 
variable, for example: 
sitecore/content/Home/Standard-Items/Register-

Form/Big-Check 

5. Click Save to save the test variable. 

6. Repeat this procedure for each test variable.  
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Link each variable to one of the content items that you want to test. 

7. Publish the new test variables. In the publishing wizard, select the Smart Publish option. 

2.4.4 Configuring Multivariate Tests 

To activate a multivariate test on your website, you must edit the layout properties of the page where 
you want to place the test. You can do this in the Page Editor or in the Content Editor.  

Configuring Multivariate Tests in the Page Editor 

1. In the Sitecore Desktop, click Sitecore, and then click Page Editor. 

2. In the Page Editor, navigate to the page that you want to place the test on. In this case, the 
Home page.  

3. Click the Toggle the ribbon button  to display the ribbon. 

4. In the ribbon, click the View tab and in the Enable group, select the Designing check box to 
enable the design functionality in the Page Editor. 

5. On the Home page, select the Register for our Newsletter item to see the design options for 
this item. 

 



Sitecore OMS 1 Online Marketing Suite Cookbook   

 

Sitecore® is a registered trademark. All other brand and product names are the property of their respective holders. The 
contents of this document are the property of Sitecore. Copyright © 2001-2010 Sitecore. All rights reserved.  

Page 19 of 55 

6. Click the Properties button  to open the Properties dialog box for this control. 

 

7. In the Properties window, scroll down to the Test Lab section, and select the Newsletter 
Form test. 

8. Click OK. 

9. In the Page Editor, click Save. 

Now when a visitor comes to the website, a register form control is displayed on the home page. The 
same register form control is displayed for the entire duration of the browser session. When a visitor 
closes the browser window, they end the session. When a visitor returns to start a new session, a 
different register form variable is displayed.  

This enables you to test each variable so you can find out which control is the most effective. 

Sitecore Analytics contains an MV Test report that lets you evaluate your multivariate tests. This 
report includes the following information: 

 Summary data for each test. 

 Percentage of session visits per test variable. 

 Number of session visits per test variable. 

 Percentage of session conversions per test variable. 

 Number of session conversions per test variable. 
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2.5 Personalization 

Personalization allows you to deliver targeted content to specific site visitors. An appropriate time to 
implement this is after segmentation has enabled you to identify the visitors that you most want to 
target. 

You can create rules to show or hide content to site visitors based on their browsing behavior and 
accumulated profile values.  

You can make your site respond in real-time by showing or hiding content, adjusting the behavior of a 
web control or by running a multivariate test. 

2.5.1 Pre-requisites 

Before you can create personalization rules you need the following components: 

 Content items to use as the data source for the conditional renderings. 

 A Web control or rendering item. 

2.5.2 Creating Personalization Rules 

In Sitecore Analytics, you can create rules to determine which content is shown to different site 
visitors. This is called conditional rendering. You create conditional rendering rules in the Marketing 
Center. 

To create a conditional rendering rule: 

1. Open the Marketing Center. 

2. In the content tree, click Personalization and then click Rules. 

 

3. To create a new rule, in the Home tab, in the Insert group, click Conditional Rendering Rule. 

4. Give the rule a name, for example, Show Brochure to Leads and then click Save. 

5. In the new rule item, in the Name field, enter the name of the rule. This is the same name that 
will appear in the Designer when you configure your rule. 
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6. In the Rule field, click Edit Rule. 

 
7. In the Rule Set Editor dialog box, select a condition and an action for your rule. 

 

Rules Example 

This example demonstrates how to create a rule that determines when new site visitors will see the 
Office Core brochure link. 

On the Office Core site, a brochure download link is displayed on every page, apart from the home 
page. This rule will specify that the brochure link on the Our Services page is not displayed to new 
visitors unless they attain a lead score of 20 or more. 

1. In the Marketing Center, create a new rule called Hide for New Visitors. 

2. In the Hide for New Visitors item, in the Rule field, click Edit Rule to open the Rule Set 
Editor dialog box. 



Sitecore OMS 1 Online Marketing Suite Cookbook   

 

Sitecore® is a registered trademark. All other brand and product names are the property of their respective holders. The 
contents of this document are the property of Sitecore. Copyright © 2001-2010 Sitecore. All rights reserved.  

Page 22 of 55 

3. In the Rule Set Editor dialog box, in the Select the conditions for the rule section, scroll 
down and select the following rule: 

“Where the value of specific profile key compares to specific value”  

This rule is now displayed in the Rule description section.  

 

Now you must edit the values in this condition so that only visitors who have accumulated a 
lead score of 20 or more can see the brochure download link.  

4. In the Rule description section, click ―specific” to open the Select Profile Key dialog box.  

 

5. In the Select Profile Key dialog box, expand Score and select Lead. 

6. In the Rule Set Editor dialog box, in the Rule description section, click ―compares to”, to 
select a comparison to use in this rule.  

7. In the Select Comparison dialog box, select ―is less than or equal to” and click OK. 

 

8. In the Rule Set Editor dialog box, in the Rule description section, click ―specific value”, to 
enter a numerical value.  

In this example, you want the brochure download link to be displayed on the Our Services 
page when the Lead profile score is higher than 20. 
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Enter ―20‖ and click OK.  

 

9. In the Rule Set Editor dialog box, in the Select the actions for the rule section, select one 
of the pre-configured actions for your rule.  

In this example, select ―hide rendering”. 

 

10. In the Rule Set Editor, click OK to save the rule. 

11. In the Marketing Center, click Save and then publish the new rule. In the publishing wizard, 
select the Smart Publish option. 

2.5.3 Configuring Personalization Rules 

To activate a personalization rule on your website, you must edit the layout properties of the page you 
want to personalize. There are two ways to do this. 

 In the Content Editor, use the Presentation tab, Layout Details dialog box. 

 In the Page Editor, use the Designing mode. 
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Configuring Personalization Rules in the Page Editor 

1. In the Sitecore Desktop, click Sitecore and then click Page Editor. 

2. In the Page Editor, navigate to the page that you want to edit.  

In this example, edit the Our Services page.  

3. In the ribbon, click the View tab and in the Enable group, select the Designing check box to 
enable to the design functionality in the Page Editor. 

4. Select the Brochure Links control and click Properties  to open the Properties dialog box. 

 

5. In the Properties window, scroll down to the Personalization section.  

 

6. Select the rule you created called — Hide for New Visitors. 

7. Click OK to close the Properties window. 

8. In the Page Editor, click Save.  
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Testing the Rule 

To test that the rule works: 

1. In a new browser window, open the Office Core website.  

2. Navigate to the Our Services page.  

Notice that there is no longer a brochure displayed in the right-hand column.  

3. Explore the site a little more and return to the Our Services page.  

Once you have accumulated a lead score of 20 or more, the brochure link will appear in the 
right-hand column. 
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Chapter 3  

Assigning Analytics Values to Content Items 

This chapter tells you how to assign profile values and scores to content items using 
the Content Editor or the Page Editor. It also explains how to associate Sitecore 
Analytics items with content items. 

 Assigning Values to Profiles and Scores 

 Associating Goals with Items 

 Associating Campaigns with Content Items 

 Assigning Events to Items 

 Assigning Failure Actions to Items 

 Analytics Page Settings 
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3.1 Assigning Values to Profiles and Scores 

Once you have created a set of profiles and profile keys you can start to assign values to content 
items on your website. You assign values to profile keys in the Content Editor or Page Editor. 

3.1.1 Assigning Profile Values to Content Items in the Page Editor  

1. Open the Page Editor and in the Office Core website, navigate to Our Services. 

2. In the Page Editor, Advanced tab, Analyze group, click Profiles to open the Profiles dialog 
box. 

 

3. In the Profiles dialog box, select the Focus check box and move the slider controls to assign 
values to each profile key. 

 

You have now assigned values to the Focus profile. 

4. Repeat this procedure for each profile key.  

Note  
Profile key values can be left blank if they are unsuitable for a content item. 
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5. When you have finished assigning values to profile keys, click OK to close the Profiles dialog 
box and to save your changes.  

Note 
If you do not select the check box next to a profile key first before editing it, the values are not 
saved. 

3.1.2 Assigning Scores 

You also use the Profiles dialog box to assign scores to content items in the same was as you assign 
profile values to content items. 

 

3.1.3 Assigning Profile Values to Content Items in the Content Editor 

You can also use the Content Editor to assign profile values to content items. 

To assign profile values to content items in the Content Editor: 

1. In the Content Editor, expand the content tree and locate the item that you want to assign 
profile values to. 

2. In the Analyze tab, in the Attributes group, click Profiles to open the Profiles dialog box. 

 

3. In the Profiles dialog box, repeat the procedure described in the previous section. 
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3.2 Associating Goals with Items 

After you create a goal in the Marketing Center, you must associate the goal with a content item.  

When a visitor navigates to a page that has a goal assigned to it, a conversion is recorded in Sitecore 
Analytics. 

In this example, you assign the Register goal to the Home item. 

How to associate a goal to a content item: 

1. Open the Content Editor.  

2. Navigate to the Home item.  

3. Click the Analyze tab and then in the Attributes group, click Goals. 

 

4. In the Goals dialog box, select the Register goal.  

5. Click OK to save your changes. 

You have now assigned the Register goal to the Home item. 
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3.3 Associating Campaigns with Content Items 

After creating a campaign in the Marketing Center, you must ensure that the campaign is triggered in 
Sitecore Analytics so you can track which campaigns your site visitors have come from. 

Online Campaigns 

An online campaign consists of a campaign definition item and a campaign event. To associate an 
online campaign with a content item, you must copy the campaign query string to the sponsored site 
and if necessary edit the query string to point to a page on your website. 

How to associate an online campaign with a content item: 

1. Open the Marketing Center.  

2. Expand the Campaigns node and then click the Google AdWords Award Winning Campaign. 

 

3. In the Campaign Link field, copy the query string. 

4. Paste the query string to your sponsored site. 

This example uses a Google AdWords campaign. 

5. Paste the campaign query string into your sponsored site. 

 

You must append the query string to your site URL. In this example the website URL is: 

www.sitecore.net/default.aspx  

The query string provided for this campaign is: 

sc_camp=E0E6A1A02F5342F1BC30DABCC3670A20 

After you insert the query string, you must insert a question mark to complete the path, as this 
is not included in the Campaign Link field: 

www.sitecore.net/default.aspx?sc_camp=E0E6A1A02F5342F1BC30DABCC3670A20 
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6. By default the campaign query string links to your home page. To point to a different page, 
you must edit the query string.  

For example, you could replace /default.aspx? with /Our-Services.aspx? 

 

When a visitor comes to your website from this campaign, a campaign event is triggered in Sitecore 
Analytics, and this is recorded in the Latest Human Sessions report.  

Offline Campaigns 

An offline campaign consists of a campaign definition item, a campaign event, and a landing page 
that can be reached using an alias. 

To activate an offline campaign, you use the Content Editor to associate the campaign event with a 
landing page. In this example, you associate the AD08 campaign with the Architectural-Digest-May-08 
landing page. 

To associate an offline campaign with a landing page: 

1. Open the Content Editor. 

2. In the Content Editor content tree, navigate to the Standard-Items folder. Open the Landing-
Pages folder and then select the Architectural-Digest-May08 content item. 

3. In the Analyze tab, in the Attributes group, click Attributes to open the Attributes dialog 
box. 

 

4. In the Attributes dialog box, select the AD08 campaign.  

5. Click OK. 

Now when visitors come to your site from this campaign, a campaign event is triggered and this is 
recorded in the Latest Human Sessions report in Sitecore Analytics. 
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3.4 Assigning Events to Items 

Events are used to track user activity on a website. They help to build up a more comprehensive 
picture of a visitor’s behavior as they navigate through the website. 

Goal and campaign events are triggered when visitors achieve certain objectives on the website or 
when they come to a site from a promotion or campaign that you have created. These events are 
tracked in Sitecore Analytics and appear in the campaign and conversion tracking reports. 

You can also associate other events with content items. You can track events, such as, download, 
search, registration or logout. Sitecore administrators can create additional events if needed. 

To assign an event to a content item:  

1. In the Content Editor, expand the content tree and navigate to the content item that you want 
to assign an event to.  

2. In the Analyze tab, in the Attributes group, click Attributes to open the Attributes dialog 
box. 

3. In the Attributes dialog box, click the Events tab, and select the event that you want to 
assign to the content item. 

 

4. Click OK to save your changes and close the Attributes dialog box.  
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3.5 Assigning Failure Actions to Items 

Failure actions are another type of event. Normally page failures are recorded programmatically. You 
can, however, use failure actions to record any page failures that occur on the website in Sitecore 
Analytics.  

For example, if you have an error page that you display to site visitors when an error occurs, you can 
associate a failure action such as Page Error with this page. Then when a visitor sees this page, a 
page error is recorded in Sitecore Analytics and you can track all the page errors that occur on your 
site in this way. 

To assign a failure action to a content item: 

1. In the Content Editor, expand the content tree, and navigate to the content item that you 
want to assign a failure action to.  

2. In the Analyze tab, in the Attributes group, click Attributes to open the Attributes dialog 
box. 

3. In the Attributes dialog box, click the Failure Actions tab, and select the event that you want 
to assign to a content item. 

 

4. Click OK to save your changes and close the Attributes dialog box. 
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3.6 Analytics Page Settings  

You can also disable analytics on any content item on your website by choosing the Disable Analytics 
for this Page toggle on the Settings tab. Once you have applied this setting, the page is no longer 
visible in the visitor session trail or any other reports in Sitecore Analytics. 

This is useful if you, for example, have a page that automatically redirects visitors to another page. 
You may not want such a page to appear in reports and session trails. 

To assign a setting to a content item: 

1. In the Content Editor, expand the content tree, and navigate to the content item that you 
want to keep out of the reports.  

2. In the Analyze tab, in the Attributes group, click Attributes to open the Attributes dialog 
box. 

3. In the Attributes dialog box, click the Settings tab and select Disable Analytics for this Page 
to assign this setting to the content item. 

 

4. Click OK to save your changes and close the Attributes dialog box. 
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Chapter 4  

Analytics Reporting 

This chapter describes the Sitecore Analytics reporting system that lets you present, 
analyze, and refine all of the statistics collected by the Online Marketing Suite. 

This chapter includes instructions on: 

 Running Sitecore Analytics Reports 

 Viewing the Session Trail 

 Classifying Site Visitors 

 Subscribing to Reports 

 Linking to CRM 

 Reports 
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4.1 Running Sitecore Analytics Reports 

Sitecore Analytics contains a number of standard reports that you can run out of the box. These 
reports are grouped in the following categories: 

 

 
Marketing 
Campaigns, Goals, Site Metrics, MV Tests 
 
Sales 
Lead reports or other score information 
 
Site Health 
Slow pages, not found URLs 
 
Recent Activity 
Latest Human and Robot Sessions 
 

To open a Sitecore Analytics report: 

1. In the Sitecore Desktop, click the Sitecore button and then click Sitecore Analytics. 

2. In Sitecore Analytics, click the node you want to expand, such as Recent Activity, and then 
click the Latest Human Sessions report. 

The report is displayed in the right-hand panel of the Sitecore Analytics window.  
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Marketing 

The following table summarizes the reports you can find under the Marketing node:  
 

Marketing Reports Description 

Campaigns Lists all the campaigns. 

Campaign Details Lists all the campaign definition items and campaign 
events. 
Displays statistics on: 

 Number of visits. 

 Goal conversion rates. 

 Profile scores. 

Campaign Summary Lists all the campaign definition items. 
Displays statistics on: 

 Number of visits. 

 Goal conversion rates. 

 Profile scores. 

Conversion and Profile 
Tracking 

Displays the total goals achieved by all site visitors. 

Tracking – First Time Visitors Displays the goals achieved by first time visitors. 

Tracking – Returning Visitors Displays the goals achieved by returning visitors. 

Downloads Displays a list of all the items that have been downloaded 
with the most recent first. 

Metrics Displays the total visits, total page views and the average 
page views per visit for the website.  
Graphs illustrate the number of visitors and the number of 
page views. 

Metrics New Visitors For new visitors this report displays: 

 Total visits. 

 Total page views. 

 Average page views per visit. 
Graphs illustrate the number of visitors and the number of 
page views. 

Metrics Returning Visitors For returning visitors, this report displays: 

 Total visits. 

 Total page views. 

 Average page views per visit. 
Graphs illustrate the number of visitors and the number of 
page views. 

MV Tests For each MV Test, you can view: 

 Percentage of session visits per test variable. 

 Number of session visits per test variable. 

 Percentage of session conversions per test 
variable. 

 Number of session conversions per test variable. 

Site Search Lists all the searches made on the website. 

Top Exit Pages Lists the most popular pages viewed before visitors leave 
the website. 

Top External Search 
Keywords 

Lists the top words used in search engines such as 
Google, Yahoo and Live Search that led the visitor to your 
website. 
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Marketing Reports Description 

Top Landing Pages Visitor entry point. This report displays a list of all the web 
pages that were viewed first on the website.  

Top Pages The most viewed pages on the web site ranked in order of 
popularity. 

Top Traffic Pages A list of the websites that visitors have come from. For 
example Google.com, if a visitor found the site from a 
Google search. 

Sales 

You can configure the sales area to display your own reports. For example, if you decide to record 
lead scores, you can display lead reports for your sales team. 

It is possible to identify competitors here. Analyst and press reports are constructed in a similar way to 
competitor reports. 

Your site administrator can help you to configure reports for this area. 

Site Health 

Site Health contains reports on any failures that occur on your website. Site Health Reports can help 
you identify potential problems with your website or on your web servers. This is useful information 
that could highlight potential problem areas that require further investigation.  

Expand the Site Health node to view all the available reports: 

 
Site Health Reports Description 

Common Mistakes List the most common mistakes that occur on the web site, 
such as, no search hits found, user subscription failed, login 
failed, and so on. 

Latest Failures Lists all the latest failures on the web site, for example, if a 
visitor had difficulty logging in or if a visitor performed a local 
search that gave 0 results.  

Not Found URLs Lists all the URLs that were not found.  
If a URL is listed as Direct, it means that the visitor typed the 
address incorrectly into the browser. These are the most 
common not found URLs. 

Pages that Report Errors Lists all the pages that report errors. 

Slow Pages Lists all the pages that loaded slowly with the slowest listed 
first. 
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Recent Activity 

Recent activity reports record the latest visits to your website. 
 

Recent Activity Reports Description 

Latest Human Sessions Lists all the human visitor sessions to your website (including 
active sessions), with the most recent listed first. 

Latest Company Sessions List all company sessions, if the visitor has been classified as 
a company. 

Latest ISP Sessions List all ISP sessions, if the visitor has been classified as an 
ISP. 

Unidentified Sessions Lists all unidentified visitor sessions. 

Latest Robot Sessions Lists all the latest robot sessions.  
For example, web bots, malicious robots 

Latest Auto Detected 
Robots 

Lists all the robots that have been detected automatically. 
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4.2 Viewing the Session Trail 

Open the Latest Human Sessions report, to see a list of all the visits to your website, with the most 
recent first: 
 

 

 



Sitecore OMS 1 Online Marketing Suite Cookbook   

 

Sitecore® is a registered trademark. All other brand and product names are the property of their respective holders. The 
contents of this document are the property of Sitecore. Copyright © 2001-2010 Sitecore. All rights reserved.  

Page 41 of 55 

Click the date stamp of an individual session to open the Session report and see the details of that 
session: 
 

 

 

 

The Session report shows all the details of this site visit: 
 

Session Report Details Description 

Name Visitor company or organization. 

Country Visitor country of origin (based on IP address). 

City Visitor city of origin. 

Region Code specifying the region. 

ISP Name of Internet Service Provider. 

Referrer Web site where search originated, for example Google.com. 

Date/time Date stamp of visit. 

Visit no. Sequential visit number. 

Page Count The number of pages viewed on the site during this visit. 

Duration The length of time the visit lasted. 

Profile values Bar charts displaying profile scores for each profile key. 

Session trail All the web pages viewed during this site visit and hyperlinks that link 
back to the actual web pages. Each URL is listed with a timing 
associated with it. 
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Click the name of a visitor to open the Sessions report and see a list of all their visits to your website 
listed by date. 
 

 
 

Click on one of these sessions, to open the Session report and see detailed information about that 
particular session. 
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4.3 Classifying Site Visitors 

Sitecore analytics lets you classify the visitors that come to your website. You can classify visitors as 
coming from your own company, as competitors, as robots, and so on. These classifications can then 
be used to filter your statistics thereby improving their quality, and ultimately to improve your visitor 
segmentation. 

We recommend that you classify site visitors early and often to make your site statistics more 
meaningful. Classifying visitors benefits your organization, helps enable your sales force, and makes 
the task of personalizing content easier. 

To classify a site visitor: 

1. Open Sitecore Analytics. 

2. Expand Recent Activity and then click the Latest Human Sessions report. 

3. Select a visitor session that is unclassified. 
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4. Click Classify to open the Visitor Classification dialog box. 

 

5. In the Visitor Classification dialog box, use the sliders to select appropriate values. 

In the Office Core website we have defined the following values: 
 

Attribute Description of values 

Business, IP Address, DNS, 
This Visitor 

Select one of the following values: 

 Unclassified 

 Business Visitor 

 ISP 

 Existing Customer 

 Analyst 

 Press 

 Supplier 

 Business Partner 

 Competitor 

 My Company 

 Bot – Feed Reader 

 Bot – Search Engine 

 Bot – Unidentified 

 Bot – Auto-detected 

 Bot - Malicious 

User Agent Select one of the following values: 

 Bot – Feed Reader 

 Bot – Search Engine 

 Bot – Unidentified 

 Bot – Auto-detected 

 Bot - Malicious 
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6. Click OK to save your changes. 

Note 
These attributes and values are taken from the Office Core website to illustrate the concept of 
classification. 
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4.4 Subscribing to Reports 

You can subscribe to reports that are of special interest to you. For example, if you subscribe to a 
report for a specific site visitor, you will be sent a report every time this visitor returns to your 
website. 

To subscribe to a report: 

1. Open Sitecore Analytics. 

2. Open the report that you want to subscribe to. 

3. Click Subscribe. 

 

Sitecore already has your e-mail address as part of your Sitecore user information. When you 
have subscribed to a report, Sitecore displays the following message: 
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4.5 Linking to CRM 

You can also link the Sitecore reports with you CRM system. 

If you click on CRM, the message, not yet implemented is displayed in a web page. 

 

However, the way in which this link works depends on how CRM integration has been implemented 
on your website. 

For more information about CRM integration, contact your website administrator. 
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4.6 Reports 

There are various ways in which you can improve the relevance of Sitecore reports. 

You can: 

 Change the date range used in a report. 

 Save a report. 

 Place filters on the report. 

 Print a report. 

4.6.1 Selecting a Date Range 

When you open a report, you can see the date range for the data at the top of the report viewer.  

 

To change the date range of a report: 

1. Open a report in Sitecore Analytics. 

2. Click the date at the top of the report and a date range filter is displayed. 

 

3. In the Date Range fields, enter a start and end date directly into the date fields or alternatively 
click the calendar icons to select a dates. 

4. Click Apply to update the report and save your date selection. 

4.6.2 Saving a Report 

In Sitecore Analytics, you can save a report in a number of different formats, such as, Word, Pdf, 
XML, Excel, Text file format, and so on. Saving a report in this way is quick and easy. 
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To save a report:  

1. Open Sitecore Analytics. 

2. Open a report such as the Top Pages report. 

3. Click Save to see the options that are available. 

 

4. Select a file format, for example Microsoft Word 2007. 

 

5. Open or save the report.  

6. If you decide to save the report, you can store your report in a local folder. 

Follow the same procedure to save the report in any of the other file types. 

4.6.3 Printing a Report 

When you view a report in Sitecore, you can print it from the report viewer. 

To print a report: 

1. In Sitecore Analytics, open a report, such as the Top Pages report. 

2. Click Print. 
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3. Select one of the three available options. 

 
 

Print Option Description 

Print to Pdf Preview the report as a Pdf document in Adobe Reader or 
save it as a Pdf file. 

Print with Preview Previews the report in Internet Explorer print format. In 
Internet Explorer, click File, Print to print the report. 

Print without Preview Displays the Print dialog box 

4. In the Print dialog box, click Print. 

4.6.4 Filtering a Report 

In Sitecore Analytics, you can filter any report to change the data that it contains. 

To filter a report: 

1. In Sitecore Analytics, open a report, such as the Top Pages report. 

In this example, we limit the report so that it only displays information about a single page on 
the website. 

2. Right click the existing report and then click Duplicate. 

3. Give the duplicate report a suitable name, for example, Architectural Digest Page. 

4. Open the new report. 
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5. In the new report, click Filter to open the Filters Editor dialog box. 

 

6. In the Filters Editor dialog box, in the Select the filters section, select the where specific 
page was visited filter. 

7. In the Filter description section, click the specific page variable to open the Select Item 
dialog box. 

 

8. In the Select Item dialog box, navigate to the page that you want to use in the filter.  

In this example, we use the Standard-Items/Landing-Pages/Architectural-Digest-May08.  
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9. Select the item and click OK to save your changes. 

10. Click Save Filter to save the new filter criteria. Notice that the report only shows the page you 
specified in the filter.  

 

Note 
Administrators can create new filter criteria to expand the selection available in the Filter Editor. 

4.6.5 Filtering a Report to Segment Site Visitors 

In Sitecore Analytics, you can create filters to segment site visitors according to geography, profile or 
any other criteria. For example, you might want to create a new filter for a specific county segment, 
such as Brazil. 

Creating a New Filter 

To create a new filter: 

1. Open the Marketing Center and in the content tree, navigate to Analytics Filter/Report 
Filters/Culture. 
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2. In the Insert group, click Predefined Filter. 

 

3. Call the new item Brazil. 

4. In the Header field of the new item, type ―where the visitor is from Brazil”. 
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5. In the Filter field, click Assign. 

 

6. In the Filter Editor dialog box, select the Where visitor is from a specific country filter. 

7. In the Filter description section, click the specify country variable.  

8. In the Enter value dialog box, enter Brazil or BR, which is the country code for Brazil. 

 

9. Click OK to close the Filter Editor and save your changes. 
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Assigning an Icon to the Filter 

1. To assign an icon to your filter, open the filter item. 

2. Click the filter icon in the content item to open the Icon dialog box. 

 

3. In the Icon dialog box, open the drop down box and select Flags. 

4. Select the icon for the Brazilian flag and click OK. 

Verifying the New Filter 

To verify that the new filter as been created: 

1. In the Sitecore Desktop, click the Sitecore button and then click Sitecore Analytics. 

2. In Sitecore Analytics, open a report, such as Top Landing Pages. 

3. Click Filter.  

In the Filter Editor dialog box, verify that the new “where the visitor is from Brazil” filter is 
displayed in the list: 

 

4. Click OK to close the Filter Editor dialog box. 
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